Tuner4Tronic Programming API

Note Note

Please note: All information in this guide has been prepared with great care. Inventronics, however, does not accept liability for possible errors, changes and/or omissions. Please check www.inventronicsglobal.com or contact your sales partner for an updated copy of this guide. This technical application guide is for information purposes only and aims to support you in tackling the challenges and taking full advantage of all opportunities the technology has to offer. Please note that this guide is based on own measurements, tests, specific parameters and assumptions. Individual applications may not be covered and need different handling. Responsibility and testing obligations remain with the luminaire manufacturer/OEM/application planner.

This document describes the API of Tuner4TRONIC DLL (T4T-DLL) version 4.x. T4T-DLL provides the following features:

  • Programming of OSRAM ECGs using luminaire production files (with extention .osrtup)
  • Readback of OSRAM ECGs and saving data to a raw data file (.osrtur)
  • Reading of driver information from an OSRAM ECG in order to identify it.
  • Reading of luminaire GTIN from an OSRAM ECG
  • Other features.

It is intended for customers whose luminaire production software is a .NET application so that the user references the T4T-DLL in his application and can then call the entry points of T4T-DLL. Other types of production software such as LabView VIs, Java applications, python scripts may also work with T4T-DLL. However T4T-DLL was tested only with .NET applications. Please contact Inventronics Tuner4TRONIC support (T4Tsupport@inventronicsglobal.com) to support you integrating T4T-DLL into your luminaire production software. T4T-CMD is based on T4T-DLL. It´s an example of a .NET application that uses T4T-DLL.

T4T-DLL supports the following programming interfaces:
  • OSRAM DALI Magic
  • FEIG NFC reader ISC.PRH101
  • FEIG NFC reader CPR30
  • FEIG NFC reader ISC.MR102
  • FEIG NFC reader ISC.LR1002
  • FEIG ECCO Smart HF.BLE
  • OSRAM OT Programmer (COM Box)

Send comments on this topic to T4Tsupport@inventronicsglobal.com


Installation

As installation requirement the .Net 6 runtime must be installed on the PC running the application using the T4T-DLL.

Since version 4.x T4T-DLL is directly included in the installation of Tuner4TRONIC Production, the binary ProgrammingAPI.dll can be found in the installation directory of T4T-P 4.x (C:\Program Files (x86)\Tuner4TRONIC 4). Please check Tuner4TRONIC Tool chain to download the Tuner4TRONIC Production 4 installer.exe.


APISpecification

The DLL file is ProgrammingAPI.dll. Add a reference to that file in the application that shall use T4T-DLL. The namespace that is exposed is ProgrammingAPI. It contains several classes. The most important one is the ProgrammingAPI-Class which provides the methods for loading a production file, programming an ECG, reading back an ECG as well as other methods.

Please find below the generated software documentation. An example of a .NET command line application using the T4T-DLL is provided at the end of the document.


ProgrammingAPI Namespace

Classes
 | Class | Description
Public class | ApplicationConstants |
Public class | DeviceInfoReceivedEventArgs |
Public class | DriverInfo |
Public class | Helper |
Public class | ParameterStatusEventArgs |
Public class | ProgrammingAPI |
Public class | ProgrammingStatusEventArgs |
Public class | ReadbackFileAvailableEventArgs |
Public class | ValueEventArgs |
Structures
 | Structure | Description
Public structure | ECGInfo |
Public structure | LuminaireConfigurationInfo |
Delegates
 | Delegate | Description
Public delegate | WriteCompleteCallback |
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationConstantsParameterType |
Public enumeration | ApplicationConstantsProgInterfaceType |
Public enumeration | ApplicationConstantsReturnCode |
Public enumeration | HelperInterfaceType |
Public enumeration | ProgrammingAPIUpdateCheckEnum |


ApplicationConstants Class

Inheritance Hierarchy
SystemObject
ProgrammingAPIApplicationConstants

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class ApplicationConstants

The ApplicationConstants type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationConstants | Initializes a new instance of the ApplicationConstants class
Top
See Also

Reference

ProgrammingAPI Namespace


ApplicationConstants Constructor

Initializes a new instance of the ApplicationConstants class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ApplicationConstants()
See Also

Reference

ApplicationConstants Class


ApplicationConstants.ParameterType Enumeration

Tuner4Tronic Programming API 4.5.1.212

ApplicationConstantsParameterType Enumeration

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public enum ParameterType
Members
Member name | Value | Description
GTIN | 0 |
IdentificationNumber | 1 |
ContentFormatVersion | 2 |
VendorSpecificContent | 3 |
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ApplicationConstants.ProgInterfaceType Enumeration

ApplicationConstantsProgInterfaceType Enumeration

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public enum ProgInterfaceType
Members
Member name | Value | Description
Unknown | 0 |
DALI | 1 |
OSRSER | 2 |
NFC | 4 |
NFC_CPR | 12 |
NFC_PRH | 20 |
NFC_MR | 36 |
NFC3 | 63 |
NFC2 | 64 |
NFC_LR1002 | 66 |
DALI2 | 128 |
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ApplicationConstants.ReturnCode Enumeration

ApplicationConstantsReturnCode Enumeration

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public enum ReturnCode
Members
Member name | Value | Description
Success | 0 |
GeneralApplicationError | 1 |
TrialPeriodExpired | 2 |
ParamFile_NotReadable | 101 |
ParamFile_Invalid | 102 |
ParamFile_OldVersion | 103 |
ParamFile_IsReadOnly | 104 |
ParamFile_UpgradeFailed | 105 |
PI_NoneFound | 200 |
PI_FWVersionUnsupported | 201 |
PI_WrongTypeFound | 202 |
PI_TooManyFound | 203 |
PI_Overloaded | 204 |
PI_CommunicationError | 205 |
PI_PowerOnProgrammingInterfaceIsFailed | 206 |
NoECGConnected | 300 |
MoreThanOneECGConnected | 301 |
TooManyECGsConnected | 302 |
WrongECGTypeOrVersionConnected | 303 |
ECGProtected | 304 |
InvalidPassword | 305 |
InvalidPasswordTimelocked | 306 |
InconsistentPasswords | 307 |
ECGCommunicationFailure | 308 |
DaliShotcutOccured | 309 |
LuminaireWrongConnection | 310 |
VerificationFailed | 311 |
ProgrammingAborted | 312 |
LuminaireConfigurationNotMatching | 313 |
NFCECGPowerIsON | 314 |
ConnectedLuminaireCountExceedsBatchSize | 315 |
ECGIsProgrammedAlready | 316 |
MapLuminaireConfigurationFailed | 317 |
ProgrammingFailedDueToMisMatchInRFPassword | 318 |
NoMatchingDDFilesFoundWithGTIN | 319 |
NoMatchingDDFilesFoundWithFWVersion | 320 |
NoMatchingDDFilesFoundWithHWVersion | 321 |
NoMatchingDDFilesFoundWithFWHWVersion | 322 |
ErrorInDeviceDataBase | 323 |
IllegalHexStringValue | 324 |
PasswordsNotMatchingEcgs | 325 |
DifferentEcgsInTheBox | 326 |
NotSupportedForMultiPF | 400 |
ParameterNotSupported | 401 |
ParameterClipped | 402 |
DeviceDetectionStarted | 1,000 |
DALIAdressingStarted | 1,001 |
PreprocessingStarted | 1,002 |
ProgrammingStarted | 1,003 |
PostProcessingStarted | 1,004 |
VerificationStarted | 1,005 |
ModeSettingStarted | 1,006 |
ProgrammingFailed | 1,007 |
ProgrammingBatchSizeReached | 1,008 |
ReadFailed | 1,009 |
ReadingCanceledByUser | 1,011 |
ReadingWaitingForOneEcg | 1,012 |
ReadingInProgress | 1,013 |
ReadingDone | 1,014 |
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


DeviceInfoReceivedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ProgrammingAPIDeviceInfoReceivedEventArgs

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class DeviceInfoReceivedEventArgs : EventArgs

The DeviceInfoReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInfoReceivedEventArgs | Initializes a new instance of the DeviceInfoReceivedEventArgs class
Top
Properties
 | Name | Description
Public property | Value |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


DeviceInfoReceivedEventArgs Constructor

Initializes a new instance of the DeviceInfoReceivedEventArgs class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public DeviceInfoReceivedEventArgs(
    List<ECGInfo> ecgs
)

Parameters

ecgs List ECGInfo
See Also

Reference

DeviceInfoReceivedEventArgs Class


DeviceInfoReceivedEventArgs Properties

The DeviceInfoReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

DeviceInfoReceivedEventArgs Class


DeviceInfoReceivedEventArgs.Value Property

DeviceInfoReceivedEventArgsValue Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public List<ECGInfo> Value { get; set; }

Property Value

List ECGInfo
See Also

Reference

DeviceInfoReceivedEventArgs Class


DeviceInfoReceivedEventArgs Methods

The DeviceInfoReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

DeviceInfoReceivedEventArgs Class


DeviceInfoReceivedEventArgs.ToString Method

DeviceInfoReceivedEventArgsToString Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public override string ToString()

Return Value

String
See Also

Reference

DeviceInfoReceivedEventArgs Class


DriverInfo Class

Inheritance Hierarchy
SystemObject
ProgrammingAPIDriverInfo

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class DriverInfo

The DriverInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DriverInfo(String) | Initializes a new instance of the DriverInfo class
Public method | DriverInfo(String, String, String, String) | Initializes a new instance of the DriverInfo class
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
Fields
 | Name | Description
Public field | FWVersion |
Public field | Gtin |
Public field | HWVersion |
Public field | SerialNumber |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


DriverInfo Constructor

Overload List
 | Name | Description
Public method | DriverInfo(String) | Initializes a new instance of the DriverInfo class
Public method | DriverInfo(String, String, String, String) | Initializes a new instance of the DriverInfo class
Top
See Also

Reference

DriverInfo Class


DriverInfo(String) Constructor

Initializes a new instance of the DriverInfo class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public DriverInfo(
    string modelID
)

Parameters

modelID String
See Also

Reference

DriverInfo Class
DriverInfo Overload


DriverInfo(String, String, String, String) Constructor

Initializes a new instance of the DriverInfo class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public DriverInfo(
    string gtin,
    string fw,
    string hw,
    string sn
)

Parameters

gtin String
fw String
hw String
sn String
See Also

Reference

DriverInfo Class
DriverInfo Overload


DriverInfo Methods

The DriverInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

DriverInfo Class


DriverInfo.ToString Method

DriverInfoToString Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public override string ToString()

Return Value

String
See Also

Reference

DriverInfo Class


DriverInfo Fields

The DriverInfo type exposes the following members.

Fields
 | Name | Description
Public field | FWVersion |
Public field | Gtin |
Public field | HWVersion |
Public field | SerialNumber |
Top
See Also

Reference

DriverInfo Class


DriverInfo.FWVersion Field

DriverInfoFWVersion Field

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string FWVersion

Field Value

String
See Also

Reference

DriverInfo Class


DriverInfo.Gtin Field

DriverInfoGtin Field

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string Gtin

Field Value

String
See Also

Reference

DriverInfo Class


DriverInfo.HWVersion Field

DriverInfoHWVersion Field

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string HWVersion

Field Value

String
See Also

Reference

DriverInfo Class


DriverInfo.SerialNumber Field

DriverInfoSerialNumber Field

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string SerialNumber

Field Value

String
See Also

Reference

DriverInfo Class


ECGInfo Structure

Inheritance Hierarchy
SystemObject
SystemValueType
ProgrammingAPIECGInfo

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public struct ECGInfo

The ECGInfo type exposes the following members.

Properties
 | Name | Description
Public property | GTIN |
Public property | ModelID |
Public property | SerialNumber |
Public property | ShortAddress |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ECGInfo Properties

The ECGInfo type exposes the following members.

Properties
 | Name | Description
Public property | GTIN |
Public property | ModelID |
Public property | SerialNumber |
Public property | ShortAddress |
Top
See Also

Reference

ECGInfo Structure


ECGInfo.GTIN Property

ECGInfoGTIN Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ulong GTIN { get; set; }

Property Value

UInt64
See Also

Reference

ECGInfo Structure


ECGInfo.ModelID Property

ECGInfoModelID Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public int ModelID { get; set; }

Property Value

Int32
See Also

Reference

ECGInfo Structure


ECGInfo.SerialNumber Property

ECGInfoSerialNumber Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ulong SerialNumber { get; set; }

Property Value

UInt64
See Also

Reference

ECGInfo Structure


ECGInfo.ShortAddress Property

ECGInfoShortAddress Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public byte ShortAddress { get; set; }

Property Value

Byte
See Also

Reference

ECGInfo Structure


Helper Class

Inheritance Hierarchy
SystemObject
ProgrammingAPIHelper

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static class Helper
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


Helper.InterfaceType Enumeration

HelperInterfaceType Enumeration

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public enum InterfaceType
Members
Member name | Value | Description
None | 0 |
DALI | 1 |
OSRSER | 2 |
NFC | 4 |
NFC_Com | 5 |
NFC_Ip | 6 |
ListGenerator | 100 |
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


LuminaireConfigurationInfo Structure

Inheritance Hierarchy
SystemObject
SystemValueType
ProgrammingAPILuminaireConfigurationInfo

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public struct LuminaireConfigurationInfo

The LuminaireConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | BasicCode |
Public property | GTIN |
Public property | ModelID |
Public property | Multiplicity |
Public property | NAEDCode |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


LuminaireConfigurationInfo Properties

The LuminaireConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | BasicCode |
Public property | GTIN |
Public property | ModelID |
Public property | Multiplicity |
Public property | NAEDCode |
Top
See Also

Reference

LuminaireConfigurationInfo Structure


LuminaireConfigurationInfo.BasicCode Property

LuminaireConfigurationInfoBasicCode Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string BasicCode { get; set; }

Property Value

String
See Also

Reference

LuminaireConfigurationInfo Structure


LuminaireConfigurationInfo.GTIN Property

LuminaireConfigurationInfoGTIN Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string GTIN { get; set; }

Property Value

String
See Also

Reference

LuminaireConfigurationInfo Structure


LuminaireConfigurationInfo.ModelID Property

LuminaireConfigurationInfoModelID Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public int ModelID { get; set; }

Property Value

Int32
See Also

Reference

LuminaireConfigurationInfo Structure


LuminaireConfigurationInfo.Multiplicity Property

LuminaireConfigurationInfoMultiplicity Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public int Multiplicity { get; set; }

Property Value

Int32
See Also

Reference

LuminaireConfigurationInfo Structure


LuminaireConfigurationInfo.NAEDCode Property

LuminaireConfigurationInfoNAEDCode Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public int NAEDCode { get; set; }

Property Value

Int32
See Also

Reference

LuminaireConfigurationInfo Structure


ParameterStatusEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ProgrammingAPIParameterStatusEventArgs

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class ParameterStatusEventArgs : EventArgs

The ParameterStatusEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterStatusEventArgs | Initializes a new instance of the ParameterStatusEventArgs class
Top
Properties
 | Name | Description
Public property | ReturnCode |
Public property | Value |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ParameterStatusEventArgs Constructor

Initializes a new instance of the ParameterStatusEventArgs class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ParameterStatusEventArgs(
    ApplicationConstantsReturnCode returnCode,
    string value
)

Parameters

returnCode ApplicationConstantsReturnCode
value String
See Also

Reference

ParameterStatusEventArgs Class


ParameterStatusEventArgs Properties

The ParameterStatusEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ReturnCode |
Public property | Value |
Top
See Also

Reference

ParameterStatusEventArgs Class


ParameterStatusEventArgs.ReturnCode Property

ParameterStatusEventArgsReturnCode Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ApplicationConstantsReturnCode ReturnCode { get; }

Property Value

ApplicationConstantsReturnCode
See Also

Reference

ParameterStatusEventArgs Class


ParameterStatusEventArgs.Value Property

ParameterStatusEventArgsValue Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

ParameterStatusEventArgs Class


ProgrammingAPI Class

Inheritance Hierarchy
SystemObject
ProgrammingAPIProgrammingAPI

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static class ProgrammingAPI

The ProgrammingAPI type exposes the following members.

Properties
Name | Description
Luminaire_Configuration |
Luminaire_CustomerProject |
Luminaire_Description |
Luminaire_Image |
Luminaire_Name |
Luminaire_OrderCode |
Luminaire_ProgrammingInterfaceType |
Version |
Top
Methods
Name | Description
Abort |
CheckForFamilyProgrammingUpdates |
CheckForUpdates |
ConfigureFamilyProgramming |
EcgReadback |
EcgReadbackAsync |
EcgReadbackBlocking |
EnableLabelPrinting |
GenerateDaliCommandStreamAsCSV |
GetInterfaceBasedOnDeviceId |
GetInterfaceList |
IsWorking |
LoadProductionFile |
Program(WriteCompleteCallback, Int32, Int32, Boolean) |
Program(String, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
Program(UInt16, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
ProgramAsync |
ProgramBlocking |
QueryDeviceInfo |
ReadBarcodesBlocking |
ReadDriverInfo |
ReadLuminaireGtin |
SetCloudEnable |
SetLabelDefinitionFile |
SetLumContentFormatVersion |
SetLumGTIN |
SetLumIdentificationNumber |
SetLumVendorSpecificContent(Byte) |
SetLumVendorSpecificContent(String) |
SetSpoolingFolderPath |
SetUpdateResultsEnable |
WriteParameter |
Top
Events
Name | Description
DeviceInfoReceived |
ProgrammingStatusChanged |
ProgressChanged |
ReadbackFileAvailable |
WriteParameterStatus |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ProgrammingAPI Properties

The ProgrammingAPI type exposes the following members.

Properties
Name | Description
Luminaire_Configuration |
Luminaire_CustomerProject |
Luminaire_Description |
Luminaire_Image |
Luminaire_Name |
Luminaire_OrderCode |
Luminaire_ProgrammingInterfaceType |
Version |
Top
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_Configuration Property

ProgrammingAPILuminaire_Configuration Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static IEnumerable<LuminaireConfigurationInfo> Luminaire_Configuration { get; }

Property Value

IEnumerable LuminaireConfigurationInfo
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_CustomerProject Property

ProgrammingAPILuminaire_CustomerProject Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Luminaire_CustomerProject { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_Description Property

ProgrammingAPILuminaire_Description Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Luminaire_Description { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_Image Property

ProgrammingAPILuminaire_Image Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Luminaire_Image { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_Name Property

ProgrammingAPILuminaire_Name Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Luminaire_Name { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_OrderCode Property

ProgrammingAPILuminaire_OrderCode Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Luminaire_OrderCode { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Luminaire_ProgrammingInterfaceType Property

ProgrammingAPILuminaire_ProgrammingInterfaceType Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsProgInterfaceType Luminaire_ProgrammingInterfaceType { get; }

Property Value

ApplicationConstantsProgInterfaceType
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Version Property

ProgrammingAPIVersion Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string Version { get; }

Property Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI Methods

The ProgrammingAPI type exposes the following members.

Methods
Name | Description
Abort |
CheckForFamilyProgrammingUpdates |
CheckForUpdates |
ConfigureFamilyProgramming |
EcgReadback |
EcgReadbackAsync |
EcgReadbackBlocking |
EnableLabelPrinting |
GenerateDaliCommandStreamAsCSV |
GetInterfaceBasedOnDeviceId |
GetInterfaceList |
IsWorking |
LoadProductionFile |
Program(WriteCompleteCallback, Int32, Int32, Boolean) |
Program(String, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
Program(UInt16, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
ProgramAsync |
ProgramBlocking |
QueryDeviceInfo |
ReadBarcodesBlocking |
ReadDriverInfo |
ReadLuminaireGtin |
SetCloudEnable |
SetLabelDefinitionFile |
SetLumContentFormatVersion |
SetLumGTIN |
SetLumIdentificationNumber |
SetLumVendorSpecificContent(Byte) |
SetLumVendorSpecificContent(String) |
SetSpoolingFolderPath |
SetUpdateResultsEnable |
WriteParameter |
Top
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Abort Method

ProgrammingAPIAbort Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void Abort()
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.CheckForFamilyProgrammingUpdates Method

ProgrammingAPICheckForFamilyProgrammingUpdates Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ProgrammingAPIUpdateCheckEnum CheckForFamilyProgrammingUpdates()

Return Value

ProgrammingAPIUpdateCheckEnum
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.CheckForUpdates Method

ProgrammingAPICheckForUpdates Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ProgrammingAPIUpdateCheckEnum CheckForUpdates()

Return Value

ProgrammingAPIUpdateCheckEnum
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ConfigureFamilyProgramming Method

ProgrammingAPIConfigureFamilyProgramming Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void ConfigureFamilyProgramming(
    bool forceDisable
)

Parameters

forceDisable Boolean
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.EcgReadback Method

ProgrammingAPIEcgReadback Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsReturnCode EcgReadback(
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.EcgReadbackAsync Method

ProgrammingAPIEcgReadbackAsync Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static Task<byte[]> EcgReadbackAsync(
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

Task Byte
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.EcgReadbackBlocking Method

ProgrammingAPIEcgReadbackBlocking Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static byte[] EcgReadbackBlocking(
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

Byte
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.EnableLabelPrinting Method

ProgrammingAPIEnableLabelPrinting Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void EnableLabelPrinting(
    bool isEnable
)

Parameters

isEnable Boolean
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.GenerateDaliCommandStreamAsCSV Method

ProgrammingAPIGenerateDaliCommandStreamAsCSV Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static string GenerateDaliCommandStreamAsCSV()

Return Value

String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.GetInterfaceBasedOnDeviceId Method

ProgrammingAPIGetInterfaceBasedOnDeviceId Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static List<string> GetInterfaceBasedOnDeviceId(
    HelperInterfaceType interfaceType
)

Parameters

interfaceType HelperInterfaceType

Return Value

List String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.GetInterfaceList Method

ProgrammingAPIGetInterfaceList Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static List<string> GetInterfaceList()

Return Value

List String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.IsWorking Method

ProgrammingAPIIsWorking Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static bool IsWorking()

Return Value

Boolean
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.LoadProductionFile Method

ProgrammingAPILoadProductionFile Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsReturnCode LoadProductionFile(
    string fileName,
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

fileName String
piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Program Method

ProgrammingAPIProgram Method

Overload List
Name | Description
Program(WriteCompleteCallback, Int32, Int32, Boolean) |
Program(String, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
Program(UInt16, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) |
Top
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.Program(WriteCompleteCallback, Int32, Int32, Boolean) Method

ProgrammingAPIProgram(WriteCompleteCallback, Int32, Int32, Boolean) Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void Program(
    WriteCompleteCallback callback,
    int boxProgrammingEcgNumber = 0,
    int antennaPowerSelectedIndex = 0,
    bool disablePowerOnCheck = false
)

Parameters

callback WriteCompleteCallback
boxProgrammingEcgNumber Int32 (Optional)
antennaPowerSelectedIndex Int32 (Optional)
disablePowerOnCheck Boolean (Optional)
See Also

Reference

ProgrammingAPI Class
Program Overload


ProgrammingAPI.Program(String, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) Method

ProgrammingAPIProgram(String, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void Program(
    string masterKey,
    bool verifyProgramming,
    bool enableSingleProgramming,
    bool disableFamilyProgramming,
    WriteCompleteCallback callback,
    int boxProgrammingEcgNumber = 0,
    int antennaPowerSelectedIndex = 0,
    bool disablePowerOnCheck = false
)

Parameters

masterKey String
verifyProgramming Boolean
enableSingleProgramming Boolean
disableFamilyProgramming Boolean
callback WriteCompleteCallback
boxProgrammingEcgNumber Int32 (Optional)
antennaPowerSelectedIndex Int32 (Optional)
disablePowerOnCheck Boolean (Optional)
See Also

Reference

ProgrammingAPI Class
Program Overload


ProgrammingAPI.Program(UInt16, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) Method

ProgrammingAPIProgram(UInt16, Boolean, Boolean, Boolean, WriteCompleteCallback, Int32, Int32, Boolean) Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void Program(
    ushort oemcode,
    bool verifyProgramming,
    bool enableSingleProgramming,
    bool disableFamilyProgramming,
    WriteCompleteCallback callback,
    int boxProgrammingEcgNumber = 0,
    int antennaPowerSelectedIndex = 0,
    bool disablePowerOnCheck = false
)

Parameters

oemcode UInt16
verifyProgramming Boolean
enableSingleProgramming Boolean
disableFamilyProgramming Boolean
callback WriteCompleteCallback
boxProgrammingEcgNumber Int32 (Optional)
antennaPowerSelectedIndex Int32 (Optional)
disablePowerOnCheck Boolean (Optional)
See Also

Reference

ProgrammingAPI Class
Program Overload


ProgrammingAPI.ProgramAsync Method

ProgrammingAPIProgramAsync Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static Task<ProgrammingErrorsEnum> ProgramAsync(
    int boxProgrammingEcgNumber = 0,
    int antennaPowerSelectedIndex = 0,
    bool disableFamilyProgramming = false,
    bool disablePowerOnCheck = false
)

Parameters

boxProgrammingEcgNumber Int32 (Optional)
antennaPowerSelectedIndex Int32 (Optional)
disableFamilyProgramming Boolean (Optional)
disablePowerOnCheck Boolean (Optional)

Return Value

Task ProgrammingErrorsEnum
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ProgramBlocking Method

ProgrammingAPIProgramBlocking Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ProgrammingErrorsEnum ProgramBlocking(
    int boxProgrammingEcgNumber = 0,
    int antennaPowerSelectedIndex = 0,
    bool disableFamilyProgramming = false,
    bool disablePowerOnCheck = false
)

Parameters

boxProgrammingEcgNumber Int32 (Optional)
antennaPowerSelectedIndex Int32 (Optional)
disableFamilyProgramming Boolean (Optional)
disablePowerOnCheck Boolean (Optional)

Return Value

ProgrammingErrorsEnum
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.QueryDeviceInfo Method

ProgrammingAPIQueryDeviceInfo Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void QueryDeviceInfo()
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ReadBarcodesBlocking Method

ProgrammingAPIReadBarcodesBlocking Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsReturnCode ReadBarcodesBlocking(
    out string Barcode,
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

Barcode String
piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ReadDriverInfo Method

ProgrammingAPIReadDriverInfo Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsReturnCode ReadDriverInfo(
    out DriverInfo driverInfo,
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

driverInfo DriverInfo
piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ReadLuminaireGtin Method

ProgrammingAPIReadLuminaireGtin Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static ApplicationConstantsReturnCode ReadLuminaireGtin(
    out string luminaireGtin,
    HelperInterfaceType piType = HelperInterfaceType.None,
    string piName = ""
)

Parameters

luminaireGtin String
piType HelperInterfaceType (Optional)
piName String (Optional)

Return Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetCloudEnable Method

ProgrammingAPISetCloudEnable Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetCloudEnable(
    bool isEnable
)

Parameters

isEnable Boolean
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLabelDefinitionFile Method

ProgrammingAPISetLabelDefinitionFile Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLabelDefinitionFile(
    string labelDefFile
)

Parameters

labelDefFile String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLumContentFormatVersion Method

ProgrammingAPISetLumContentFormatVersion Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLumContentFormatVersion(
    int value
)

Parameters

value Int32
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLumGTIN Method

ProgrammingAPISetLumGTIN Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLumGTIN(
    long value
)

Parameters

value Int64
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLumIdentificationNumber Method

ProgrammingAPISetLumIdentificationNumber Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLumIdentificationNumber(
    ulong value
)

Parameters

value UInt64
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLumVendorSpecificContent Method

ProgrammingAPISetLumVendorSpecificContent Method

Overload List
Name | Description
SetLumVendorSpecificContent(Byte) |
SetLumVendorSpecificContent(String) |
Top
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetLumVendorSpecificContent(Byte[]) Method

ProgrammingAPISetLumVendorSpecificContent(Byte) Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLumVendorSpecificContent(
    byte[] value
)

Parameters

value Byte
See Also

Reference

ProgrammingAPI Class
SetLumVendorSpecificContent Overload


ProgrammingAPI.SetLumVendorSpecificContent(String) Method

ProgrammingAPISetLumVendorSpecificContent(String) Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetLumVendorSpecificContent(
    string value
)

Parameters

value String
See Also

Reference

ProgrammingAPI Class
SetLumVendorSpecificContent Overload


ProgrammingAPI.SetSpoolingFolderPath Method

ProgrammingAPISetSpoolingFolderPath Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetSpoolingFolderPath(
    string spoolingFolderName
)

Parameters

spoolingFolderName String
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.SetUpdateResultsEnable Method

ProgrammingAPISetUpdateResultsEnable Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void SetUpdateResultsEnable(
    bool isEnable
)

Parameters

isEnable Boolean
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.WriteParameter Method

ProgrammingAPIWriteParameter Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static void WriteParameter(
    ApplicationConstantsParameterType parameterType,
    Object setValue
)

Parameters

parameterType ApplicationConstantsParameterType
setValue Object
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI Events

The ProgrammingAPI type exposes the following members.

Events
Name | Description
DeviceInfoReceived |
ProgrammingStatusChanged |
ProgressChanged |
ReadbackFileAvailable |
WriteParameterStatus |
Top
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.DeviceInfoReceived Event

ProgrammingAPIDeviceInfoReceived Event

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static event EventHandler<DeviceInfoReceivedEventArgs> DeviceInfoReceived

Value

EventHandler DeviceInfoReceivedEventArgs
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ProgrammingStatusChanged Event

ProgrammingAPIProgrammingStatusChanged Event

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static event EventHandler<ProgrammingStatusEventArgs> ProgrammingStatusChanged

Value

EventHandler ProgrammingStatusEventArgs
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ProgressChanged Event

ProgrammingAPIProgressChanged Event

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static event EventHandler<ValueEventArgs> ProgressChanged

Value

EventHandler ValueEventArgs
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.ReadbackFileAvailable Event

ProgrammingAPIReadbackFileAvailable Event

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static event EventHandler<ReadbackFileAvailableEventArgs> ReadbackFileAvailable

Value

EventHandler ReadbackFileAvailableEventArgs
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.WriteParameterStatus Event

ProgrammingAPIWriteParameterStatus Event

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public static event EventHandler<ParameterStatusEventArgs> WriteParameterStatus

Value

EventHandler ParameterStatusEventArgs
See Also

Reference

ProgrammingAPI Class


ProgrammingAPI.UpdateCheckEnum Enumeration

ProgrammingAPIUpdateCheckEnum Enumeration

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public enum UpdateCheckEnum
Members
Member name | Value | Description
Timeout | 0 |
UpdateAvailable | 1 |
NoUpdates | 2 |
Error | 3 |
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ProgrammingStatusEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ProgrammingAPIProgrammingStatusEventArgs

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class ProgrammingStatusEventArgs : EventArgs

The ProgrammingStatusEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammingStatusEventArgs | Initializes a new instance of the ProgrammingStatusEventArgs class
Top
Properties
 | Name | Description
Public property | ReturnCode |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ProgrammingStatusEventArgs Constructor

Initializes a new instance of the ProgrammingStatusEventArgs class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ProgrammingStatusEventArgs(
    ApplicationConstantsReturnCode returnCode
)

Parameters

returnCode ApplicationConstantsReturnCode
See Also

Reference

ProgrammingStatusEventArgs Class


ProgrammingStatusEventArgs Properties

The ProgrammingStatusEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ReturnCode |
Top
See Also

Reference

ProgrammingStatusEventArgs Class


ProgrammingStatusEventArgs.ReturnCode Property

ProgrammingStatusEventArgsReturnCode Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ApplicationConstantsReturnCode ReturnCode { get; }

Property Value

ApplicationConstantsReturnCode
See Also

Reference

ProgrammingStatusEventArgs Class


ReadbackFileAvailableEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ProgrammingAPIReadbackFileAvailableEventArgs

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class ReadbackFileAvailableEventArgs : EventArgs

The ReadbackFileAvailableEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReadbackFileAvailableEventArgs | Initializes a new instance of the ReadbackFileAvailableEventArgs class
Top
Properties
 | Name | Description
Public property | FileAsByteArray |
Public property | Fw |
Public property | Gtin |
Public property | Hw |
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ReadbackFileAvailableEventArgs Constructor

Initializes a new instance of the ReadbackFileAvailableEventArgs class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ReadbackFileAvailableEventArgs(
    byte[] osrturFileByteArray,
    string gtin,
    string fw,
    string hw
)

Parameters

osrturFileByteArray Byte
gtin String
fw String
hw String
See Also

Reference

ReadbackFileAvailableEventArgs Class


ReadbackFileAvailableEventArgs Properties

The ReadbackFileAvailableEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileAsByteArray |
Public property | Fw |
Public property | Gtin |
Public property | Hw |
Top
See Also

Reference

ReadbackFileAvailableEventArgs Class


ReadbackFileAvailableEventArgs.FileAsByteArray Property

ReadbackFileAvailableEventArgsFileAsByteArray Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public byte[] FileAsByteArray { get; set; }

Property Value

Byte
See Also

Reference

ReadbackFileAvailableEventArgs Class


ReadbackFileAvailableEventArgs.Fw Property

ReadbackFileAvailableEventArgsFw Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string Fw { get; set; }

Property Value

String
See Also

Reference

ReadbackFileAvailableEventArgs Class


ReadbackFileAvailableEventArgs.Gtin Property

ReadbackFileAvailableEventArgsGtin Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string Gtin { get; set; }

Property Value

String
See Also

Reference

ReadbackFileAvailableEventArgs Class


ReadbackFileAvailableEventArgs.Hw Property

ReadbackFileAvailableEventArgsHw Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public string Hw { get; set; }

Property Value

String
See Also

Reference

ReadbackFileAvailableEventArgs Class


ValueEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ProgrammingAPIValueEventArgs

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public class ValueEventArgs : EventArgs

The ValueEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ValueEventArgs | Initializes a new instance of the ValueEventArgs class
Top
Properties
 | Name | Description
Public property | Value |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


ValueEventArgs Constructor

Initializes a new instance of the ValueEventArgs class

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public ValueEventArgs(
    int value
)

Parameters

value Int32
See Also

Reference

ValueEventArgs Class


ValueEventArgs Properties

The ValueEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

ValueEventArgs Class


ValueEventArgs.Value Property

ValueEventArgsValue Property

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public int Value { get; set; }

Property Value

Int32
See Also

Reference

ValueEventArgs Class


ValueEventArgs Methods

The ValueEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ValueEventArgs Class


ValueEventArgs.ToString Method

ValueEventArgsToString Method

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public override string ToString()

Return Value

String
See Also

Reference

ValueEventArgs Class


WriteCompleteCallback Delegate

Namespace: ProgrammingAPI
Assembly: ProgrammingAPI (in ProgrammingAPI.dll) Version: 4.5.1.212 (4.5.1.212)
Syntax
C#
Copy
public delegate void WriteCompleteCallback(
    ApplicationConstantsReturnCode programmingStatus
)

Parameters

programmingStatus ApplicationConstantsReturnCode
See Also

Reference

ProgrammingAPI Namespace
Send comments on this topic to T4Tsupport@inventronicsglobal.com


Sample

Below is an example for programming a driver.

Reference the ProgrammingAPI.dll in your project and copy all dll from the T4T-P installation directory to the output directory.

Sample code

C#
Copy
using System;
using System.Threading;
using ProgrammingAPI;

namespace Sample
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine($"Programming {args[0]} into the device:");
            var res = ProgrammingAPI.ProgrammingAPI.LoadProductionFile(args[0]);
            ProgrammingAPI.ProgrammingAPI.ProgrammingStatusChanged += ProgrammingAPI_ProgrammingStatusChanged;
            ProgrammingAPI.ProgrammingAPI.ProgressChanged += ProgrammingAPI_ProgressChanged;
            bool done = false;
            // use the WriteCompleted callback to detect end of programming
            ProgrammingAPI.ProgrammingAPI.Program(a =>
            {
                Console.WriteLine(a);
                done = true;
            });
            // wait until programming is completed
            while (!done)
            {
                Thread.Sleep(100);
            }
            Console.WriteLine("Press any key to quit");
            Console.ReadKey(true);
        }

        private static void ProgrammingAPI_ProgressChanged(object sender, ValueEventArgs e)
        {
            Console.WriteLine($"Progress {e.Value}%");
        }

        private static void ProgrammingAPI_ProgrammingStatusChanged(object sender, ProgrammingStatusEventArgs e)
        {
            Console.WriteLine(e.ReturnCode);
        }
    }
}