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 Introduction 1.

1.1 General 
The OSRAM DALI PROFESSIONAL System (DALI PRO System) is a lighting control based on 
standardized DALI Bus according to IEC 62386, see: http://www.dali-ag.org/. 

With this, a flexible addressable digital lightning control can be built-up. The central component is the 
DALI PRO CONTROLLER with 4 DALI lines. These DALI lines can be equipped with DALI suitable 
ECG for lamp operation and DALI operation units / sensors. 

The DALI PRO PC software allows a comfortable setup and visualization of individual configurations 
for the DALI PRO system. Complete configurations can be shown and changed on the screen with 
mouse clicks.  

Changes on screen are transferred by upload from PC to the controller memory via USB or remotely 
by local LAN connection. 

The DALI PRO PC software provides various possibilities which are all described in detail by software 
manual.  

 

This document provides: 

• a general step by step instructions for commissioning the DALI PROFESSIONAL new features, 
see 2 General introduction to adding and configuring new features, page 6 

• an introduction to DALI PROFESSIONAL new features: 

o Color Control (RGB), see chapter 3, page 12 

o Tunable White, see chapter 4, page 26 

o Daylight simulation, see chapter 5, page 36 

o Smartphone configuration, see chapter 6, page 39 

1.2 System limits 

1.2.1 DALI PRO Cont-4 RTC functionalities and limitations 

- 4 x 16+ groups, line overlapping allowed; '+' means additional 'virtual' groups possible by 
software, but uses addressed commands. Final max. number of groups only limited by 
controller memory  

- 4 x 16 scenes, line overlapping allowed, but then one scene used for each line 
- 4 x 8 active light regulation loops; more possible when noticeable delay accepted, limited by 

reaction times 
- Full- and semi-automatic energy saver function with occupancy- and light-sensor 
- Up to 10 light sensors / sensor couplers per regulation 
- Corridor function with two standby levels 
- PIR disable / enable function 
- Sequences consisting of scenes, fade control, loops 
- Visible resource status message  
- Switch function  
- Serial / parallel configuration of grouped switches  
-  4 x programmable internal relay  
- Test-function for all DALI devices 
- Configuration check comparing physical available devices  
- Retrieve configuration by download from controller  
- Full project documentation in HTML file  
- Up to 50 different configurable timers 

http://www.dali-ag.org/
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1.3 Required equipment 
All DALI PROFESSIONAL commissioning responsible should have a recommended tool kit in their 
possession. 

1.3.1 Additional equipment for Smartphone control 

To control a DALI PRO CONT-4 RTC controller with a smartphone the following equipment is needed 
in addition to the standard equipment: 

• A standard Wifi router 

• A RJ45 Cat 5 patch cable between wireless IT-switch and controllers 
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 General introduction to adding and configuring new 2.
features 

This section describes some fundamental functions of the DALI Professional software. 

To enable, generate and configure a new feature always takes the following steps which are explained 
in depth in chapters 2.1 to 2.5:  

 Enable a feature, see 2.1, page 6. 1.

 Generate devices, see 2.2, page 7. 2.

 Generate a button for a device, see 2.3, page 10. 3.

 Create a function to connect button and device, see 2.4, page 10. 4.

 Configure the functionalities for the button, see 2.5, page 11. 5.

In case you are an advanced user, please continue with chapter 3 to 5. 

2.1 Enable a feature 
Before generating a new device for a feature, the feature has to be enabled. 

 

 
 Select the corresponding controller (1). 1.

 Click Settings (2) to open the Project Features list. 2.

 Set Yes for the required features (3). 3.

 Confirm by clicking Ok (4). 4.

1 

2 

3 

4 
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2.2 Generate a device 
Before using a feature, a device of this feature has to be generated. 

Devices can be:  

• Used (connected) devices 
With the localization window, the connected devices can be added to the device tree. 
See 2.2.2 Generate used devices from the localisation window, page 8. 

• Virtual devices (for planning/preconfiguration purposes) 
These devices can be merged later to used devices. 
In the device tree, virtual devices can be added manually. 
See 2.2.1 Generate a virtual device from the device tree, page 7. 

2.2.1 Generate a virtual device from the device tree 

 

 
 

 Select with right-mouse-click: Ballasts > Single Ballasts > Add devices (1).  1.

 Select the type of device (feature) (2) and the number of devices (3). 2.

2 
1 

2 

3 3 
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2.2.2 Generate used devices from the localisation window 

INFO: The localisation window is only available, when the PC is connected to the DALI PRO Cont-4 
RTC controller. 

Prerequisites: A device scan (1) is done. 

 

  
 Select Ballasts > Locate devices (2).  1.

The connected devices (ECGs, couplers) are shown in the Devices to localise list. 
The list can be filtered (e.g. by port). 

 Optional: Select Ballasts > Locate devices (2) to skip the device scan and directly open the 2.
Localisation window; requires one Scan for devices (1) after connecting.. 

2.2.3 Group devices 

The localized devices can be grouped. 

Adding a new group: 

 Select the Group tab (3). 1.

 Select a feature (4). 2.

 Click + to generate a new group (5). 3.

 

Adding a device to a group: 

 Select a device in the list (6). The actual selected device is blinking. 1.

 Select a group (7). 2.

 Click >> (8) to add the selected device to the selected group (7). 3.

2 

3 4 

5 

6 

7 

1 

8 
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2.2.4 Mapping options 

It is possible to set mapping options for one or all ports. 

INFO: It is recommended to select Non selected ECG > Off (3). 

 

 
 

 Select Device name (1). 1.

 Click Settings (2).  2.

 Select the required settings in the Mapping Options window, see following table. 3.

 Confirm with OK. 4.

Option Explanation 

On While the localization window is running, all non selected luminaires 
are on. 

Minimum level While the localisation window is running, all non selected ECG are at 
minimum level. 

Off Recommended setting! 
While the localisation window is running, all non selected ECGs are off. 

Switch on or off mapped 
ECG 

While the localisation window is running, all mapped ECGs are on or 
off to easier identify unmapped ECGs. 

Reduce disturbing for 
simple selection 

While the localisation window is running, only the selected ECG is 
blinking, and the others are working as normal (only used when the 
system was already running to minimize interruption of the normal 
work). 

1 2 

3 
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2.3 Generate a button for a device 
In order to use a device, a button has to be generated.  
 

         
 

 Select with right-mouse-click: Coupler > Button > Add devices (1). 1.

 Select the number of buttons (2). 2.

 Confirm with OK. 3.

2.4 Create a function 
In order to have the device respond to a button action, button and device have to be connected. This 
allows for a function to be executed. 
 

 

 
 Drag the button (1) from the device tree into the Graph Panel (1a). 1.

 Drag the device (2) from the device tree into the Graph Panel (2a). 2.

 Drag a line from the button to the device to connect them (3). 3.

  

1a 2a 

3 

1 2 

1 

2 
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2.5 Configure the functionalities of a button 
In order to set multiple button functionalities, the button has to be configured in the properties window. 

 

 
 

 Select the button function (1). 1.

 Select the action(s) and the corresponding effect(s) from the Properties window (2), see 3.3 Add 2.
and configure buttons, page 13. 

1 

2 
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 Color Control (RGB) 3.

3.1 General 
• To control colored light, an RGB device (1) has to be generated by combining three DALI ECGs 

with red, green and blue light. 

• For RGB functions, only combined RGB devices can be used.  

• The single ECGs (of a combined RGB device) are shown in orange (2) and no longer usable. 

 
 

INFO: The DALI Device Type 8 for colored light is not supported by the DALI PRO-Cont4 RTC 
controller. 

3.2 Add RGB device and configure basic settings 

3.2.1 Adding RGB device 

 
 Enable the RGB functions in the Project Features list, see 2.1 Enable a feature, page 6. 1.

 In the device tree, select with right-mouse-click: Ballasts > Single Ballast > Add devices. (For 2.
details see 2.2 Generate a device page 7). . 

 Select the number of RGB devices and confirm. 3.

 Drag the device from the device tree into the Graph Panel. 4.

 Select the RGB group (1). 5.

 Configure the device in the Properties window (2). 6.

  

1 

2 

1 

2 
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3.2.2 Configuration settings 

Option Explanation Parameters/Examples 

Title Rename the RGB device. e.g. Foyer RGB lightwall 1 

Comment Add a comment for further information. e.g. device located above 
luminaire 

Power on 
behavior 

Light on situation: 
- Go to last level: Light on – with values 

from the situation before the power loss  
- Go to level: light level after power cycle 

Power On Level (0 – 100 %) 
Color (RGB settings), see 
3.3.7 Setting a color value, 
page 17. 

Linear dimming 
curve 

Enable dimming. No  
Yes (light level will stay 
constant when changing the 
color, optimized for RGB) 

Use in zones Lists zones, where RGB device is used. e.g. conference room 

3.3 Add and configure buttons 

3.3.1 Adding buttons 

Usually, button actions are combined to utilize the full scope of functionalities.  

 

 
 Select a button function (1). 1.

 Configure the button in the Properties window (2), see following tables. 2.

 If required, add more than one button function to the Action mapping box (3) and configure them. 3.

1 

2 

3 
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3.3.2 General settings 

Option Explanation Parameters/Examples 

Fade Time Duration to dim to the new 
brightness level. 

Default (uses fade time stored from the 
ECGs) 
No fade 
0.7 – 90.5 s 

Short Push Select action for a short push 
on a button. 

See 3.3.4 Short Push actions, page 15. 
 

Long Push Select action for a long push 
on a button. 

See 3.3.5 Long Push actions, page 16. 

Double Push Select action for a double push 
on a button. 

See 3.3.6 Double Push actions, page 16. 

Delayed action Define up to two delayed 
actions for a Short Push. 

No 
1 (number of delayed actions), see 3.3.3 
Delayed action configuration options, page 
14. 
2 (number of delayed actions), 
See 3.3.3 Delayed action configuration 
options, page 14. 

3.3.3 Delayed action configuration options 

Option Explanation Parameters/Examples 

Time Delay Step 1: Delay time until the 
first delayed action starts. 
Step 2: Delay time between 
the first and the second 
delayed action. 

 

Fade Time Duration to dim to the new 
brightness level. 

 

Action Delayed action type: 
- Off 
- Go to level 

Level (0 – 100 %) 
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3.3.4 Short Push actions 

The following functionalities are available for Short Push button actions:16 

Short Push action Explanation Parameters/Examples 

Off Switch off the light.  

Go to level Light on – dim brightness to parameter 
value. 

Level (0 – 100 %) 

Go to last level Light on – with values from the 
situation before the last light off. 

 

Go to scene Light on to scene, selected by name. Scene, see 3.4 Add and configure 
a colored scene page 18. 

Go to next scene Light on to the scene, selected by 
name. 
If Scene 1 is already running, Scene 2 
will be recalled by pressing the button 
– loop with each button press. 

Scenes count (numbers, up to five 
scenes possible) 
Scene 1 
Scene 2 
Scene 3 … 

Toggle (level) Toggle between off and the light value 
from the additional parameter level. 

Level (0 – 100 %) 

Toggle (last level) Toggle between off and the level value 
from the situation of the last light on. 

 

Toggle (scene) Toggle between off and the scene, 
selected by name. 

Scene, see 3.4 Add and configure 
a colored scene page 18. 

Go to Color Light on to selected color. Color (RGB settings), see 3.3.7 
Setting a color value, page 17. 
 

Go to Color and 
Level 

Light on to selected color and level. Level (0 – 100 %) 
Color (RGB settings), see 3.3.7 
Setting a color value, page 17. 

 

INFO: The following effects are only visible, when an effect (RGB sequence, Daylight Simulation) is 
connected to the Action Mapping box: 
- Start Effect 
- Stop Effect 
- Toggle Effect 

 

Start Effect Start an color effect, see 3.5 Add and 
configure a color effect (RGB 
sequence), page 21. 

 

Stop Effect Stop an color effect, see  3.5 Add and 
configure a color effect (RGB 
sequence), page 21. 

 

Toggle Effect Toggle effect, see 3.5 Add and 
configure a color effect (RGB 
sequence), page 21. 
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3.3.5 Long Push actions 

The following functionalities are available for Long Push button actions: 

Long Push action Explanation 

Dimming Continuous change of the level. With each long push, the dimming 
direction is changed. 

Dimming Up Continuous change to more light (for button with label up). 

Dimming Down Continuous change to less light (for button with label down). 

RGB circle Walk through the colors of the RGB circle (over 32 different colors).  

RGB circle with white Walk through the colors of the RGB circle, including white. 

Change Red/Green/Blue Change color value of Red, Green or Blue. 

Increase Red/Green/Blue Increase color value of Red, Green or Blue. 

Decrease 
Red/Green/Blue 

Decrease color value of Red, Green or Blue. 

3.3.6 Double Push actions 

The following functionalities are available for Double Push button actions: 

Double Push action Explanation Parameters/Examples 

Off Switch off the light.  

Go to level Light on – dim brightness to 
parameter value. 

Level (0 – 100 %) 

Go to scene Light on to scene, selected by 
name 

Scene, see 3.4 Add and configure a 
colored scene page 18. 

Go to Color and Level Light on to selected color and 
level. 

Level (0 – 100 %) 
Color (RGB settings), see 3.3.7 
Setting a color value, page 17. 
 

 

INFO: The following effects are only visible, when an effect (RGB sequence, Daylight Simulation) is 
connected to the Action Mapping box: 
- Start Effect 
- Stop Effect 

 

Start Effect Start a color effect, see 3.5 Add and 
configure a color effect (RGB 
sequence), page 21. 

 

Stop Effect Stop a color effect, see 3.5 Add and 
configure a color effect (RGB 
sequence), page 21. 
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3.3.7 Setting a color value 

All RGB values can manually be added to the devices. Each single color is a combination of RGB 
values. 

On order to set a color value for one or more button actions, use one of the following options: 

Option 1: Click the list (1), to open the RGB circle and select a color. Confirm with OK. 

 
 

Option 2: Set the exact values (2) for Red, Green and Blue, e.g. to set the exact CI color values of a 
company. 

 

1 

2 
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3.4 Add and configure a colored scene 
• In addition to the light level, the color control for each RGB output will be shown in the scene 

panel. 

• It is also possible to have one button correspond with up to five scenes (Short Push > Go to next 
scene). 

3.4.1 Adding a colored scene 

 

 
 Select the required Action Mapping box in the Graph Panel, in order to select the outputs that will 1.

be affected by the scene. 

 Click the list (1) and activate the Scene tab (2). 2.

 Click + (3) to add a scene. 3.

 Rename the scene (4) in the window. 4.

 Confirm with OK. 5.

  

1 

2 

3 

4 
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3.4.2 Configuring a colored scene 

In the scene panel, all devices to be affected by this scene are listed. 

Each device in this list can have different brightness and color levels, but they also can have the same 
settings. 

RGB and normal ECG can be mixed in the scene. 

                                                                                         

 

 
 Select the required device (1) – press [Shift] or [Strg] to select multiple devices. 1.

 Select the color values (2). 2.

 Select the brightness level (3). 3.

 If connected to the controller: Activate Live (4), to visualize the selection. Click Go on (5) after 4.
final selection to activate the configuration again. 

1 2 

2 3 

4 

1 

5 



DALI PROFESSIONAL Lighting Control System – Field Commissioning Guide  

v.2.2.x  20/51  

 

3.4.3 Recalling a scene 

 
 

Select the button function in the Graph Panel (1). 

 Select: Short Push > Go to scene (2) in the Properties window. 1.

 Select the scene (3). 2.

3.4.4 Recalling multiple scenes 

One button function can be used to toggle between multiple scenes 

 
 

 Select the button function in the Graph Panel (1). 1.

 Select: Short Push > Go to next scene (2) in the Properties window. 2.

 Select the number of scenes for the loop (3). 3.

 Select the names of the scenes (4). 4.

1 

2 

3 

1 2 

3 

4 
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3.5 Add and configure a color effect (RGB sequence) 
The color effect offers the following functionalities: 

• play an RGB sequence 

• provide an easy continuous color change.  

This procedure requires multiple steps: 

• Generating the RGB sequence. 

• Selecting a Short Push or Double Push button function for the effect, see 3.3 Add and configure 
buttons, page 13. 

• Configuring an automatic or a self-defined RGB sequence. 

3.5.1 Generating an RGB sequence 

 

 
 

 Select Advanced features > Effect > RGB sequences (1). 1.

 Drag the RGB sequence from the device tree into the Action mapping box of a button. The new 2.
RGB sequence is generated (2). 

2 

1 
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3.5.2 Selecting a button function for the RGB sequence 

To use the RGB sequence, it has to be connected to a button function. 

 
 Select the button function (1) in the Action mapping box and configure a button action for the RGB 1.

sequence, e.g. Short Push > Toggle Effect (2). 

3.5.3 Configure the RGB sequence 

Two modes are available to configure RGB sequences: 

• Auto color change mode 
Use this mode for fast comissioning if no specific color is required. 

• RGB sequence mode 
Use this mode to define an individual customizable color change. 

3.5.3.1 Configure auto color change 

The Auto color change mode uses a preconfigured automatic program to change color. 

 
 

 Select the RGB sequence (1) in the Action mapping box.  1.

 Select Auto color change mode and the required settings in the Properties window (2).  2.

Option Explanation Parameters/Examples 

Mode Preconfigured automatic color change 
program 

Auto color change 

Change Speed Time for one change through all colors. 15 s 

Start with power on Auto start after power cycle. No 
Yes 

1 

2 
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3.5.3.2 Configure an individual RGB sequence 

The RGB sequence mode allows to define a sequence of colors. 

 
 

 Select the RGB sequence (1) in the Action mapping box.  1.

 Select RGB sequence mode and the required settings in the Properties window (2), see following 2.
table.  

 Click Settings (3).  3.
Define a color sequence by modifying time/color settings (see next section). 

 

 Option 4. Explanation Parameters/Examples 

Mode Individual color change program RGB sequences 
Change level When activated the brightness level is 

configurable for each color. 
If deactivated the actual light level will 
not be changed while color change. 

Yes 
No 

Start with power on Auto Start after power cycle No 
Yes 

RGB sequence Select RGB sequence by name. Sequence name  
 

1 

2 

3 
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3.5.4 Defining color sequences 

In the Color Sequence window, sequences of colors can be configured. 

Each sequence is a list of time and color settings (1). 

   
 

 To create a new sequence, use the upper + button (3). 1.

 To modify an entry in the sequence, select it and edit entries in the configuration fields (2). 2.

 To add an entry to the sequence, use the lower + button (4). 3.

 Modify the sequence. For the complete set of functions in the window see the following tables. 4.
Confirm with OK. 

Sequence menu (6) 

Option Explanation 

 
List of available RGB sequences 

 
Rename RGB sequence. 

 
Add RGB sequence. 

 
Copy RGB sequence. 

 
Delete RGB sequence. 

 
Import RGB sequences from other other DALI PRO project files 

 
 

2 

3 

4 

1 
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Time/color settings menu (7) 

Option Explanation 

Nr. Number of time/color settings for this RGB sequence, note that  
Nr. 3 is marked in the image for further configuration. 

 
Add a time/color setting. 

 
Delete a time/color setting. 

 
Shift the selected time/color setting upward in the list. 

 
Shift the selected time/color setting downward in the list. 

 
Option for real-time visualization of the RGB sequence 

Static Time RGB values will be shown for selected time. 

Fade Time RGB values will fade within selected time. 

Color RGB color values 

Level Color level 
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 Tunable White 4.

4.1 Adding Tunable White (TW) device and configure basic settings 

4.1.1 General   

Two different types of Tunable White devices are supported. 

• TW Group as combination of standard DALI devices with warm white and cold white color 
temperature 

• TW device as DALI Device Type 8 TW device (DALI DT8 devices) 

 

Attention: DALI DT8 devices can only be integrated when connected to a controller via device scan. 
(See 2.2.2 Generate used devices from the localisation window, page 8.) 

4.1.2 Adding a TW Group with standard DALI devices 

Check prerequisites: 

Check if Tunable White feature is enabled in the Project Features list,  
see 2.1 Enable a feature, page 6. 

 

 
 

 To add a virtual TW device: 1.
In device tree, select with right-mouse-click: Ballasts > Single Ballast > Add devices. 

 Select the number of TW devices in the window and confirm. 2.

Optional: To generate a TW Group from the localization window see 2.2.2 Generate used devices 
from the localisation window, page 8.  



DALI PROFESSIONAL Lighting Control System – Field Commissioning Guide  

v.2.2.x  27/51  

 

4.1.3 Changing the color temperature 

Depending on the device the method of changing the color temperature is different. 

. 

4.1.3.1 Changing the color temperatures for a Tunable White  

It is possible to set the color temperature of the connected warm white and cold white device.  

Also the lumen output.  

 

HINT: Only change, if you have special requirements on Tunable white devices. 

   
 

 Select the Warm or the Cold channel (1) for the TW device in the device tree. 1.

 Select the required settings in the Properties window (2), see following table. 2.

 

Option Explanation Parameters/Examples 

Color Temperature Set the color temperature (in Kelvin). 2700 K 

Light output Set the light output (in Lumen). 1000 Lumen 

 

  

1 

2 
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4.1.3.2 Configuring the color temperature limits for DALI DT8 devices 

If required, minimum and maximum color temperature values can be adapted. 

Hint: The color temperature is stored in a different form in the device. The number will be changed to 
the next color temperature number available in the device. 

 
 

 
 Select with right-mouse-click: Ballasts > Single Ballast > Color Device Type – Set Up (1).  1.

The Color Device Type – Set Up window opens. 
It shows a list with TW devices and the configured temperatures (2). 

 Select a TW device in the list and click Change (3).  2.

 Configure the temperatures in the window (4). 3.
Confirm with OK. 

 Confirm with Close (5). 4.

1 

2 2 

3 

4 

5 
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4.1.4 Configuring the TW device  

To assign a coupler to a TW device, add both devices to the Graph panel and configure the 
properties. 

 
 

  
 

 Drag the button (1) from the device tree into the Graph panel (1a). 1.

 Drag the TW device (2) from the device tree into the Graph panel (2a). 2.

 Select the TW group (3). 3.

 Configure the device in the Properties window (4). 4.

4.1.4.1 Configuration settings 

Option Explanation Parameters/Examples 

Title Rename the TW device. e.g. Foyer  

Comment Add a comment for further information. e.g. device located above 
luminaire 

Power on behavior Light on situation: 
- Go to last level: Light on – with values 

from the situation before the power loss  
- Go to level: light level after power cycle 

Power On Level (0 – 100 %) 

3 

1a 2a 

1 

2 

4 
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Option Explanation Parameters/Examples 

Linear dimming 
curve 

Enable dimming. No  
Yes (light level will stay 
constant when changing the 
color temperature, optimized 
for TW) 

Color Temperature 
Range 

Warm-cold range for the TW device in 
Kelvin. See 4.1.3 Changing the color 
temperature, page 27 to set these values. 

2700 K - 8000 K 

Use in zones Lists zones, where TW device is used. e.g. conference room 
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4.2 Configuring a button 

4.2.1 Configuring functions 

Usually, button actions are combined to utilize the full scope of functionalities.  

 

  
 

 In Graph panel, connect  the TW device (Inputs) and with the button (Outputs): 1.
Click Inputs and drag mouse to Outputs. A connector line is shown. The title Inputs is changed to 
Action mapping. 

 Select a button function (1). 2.

 Configure the button in the Properties window (2), see the following tables. 3.

4.2.2 General settings 

Option Explanation Parameters/Examples 

Fade Time Duration to dim to the new brightness level. Default (uses fade time stored 
from the ECGs) 
No fade 
0.7 – 90.5 s 

Short Push Select action for a short push on a button. See 4.2.4 Short Push actions, 
page 32 
 

Long Push Select action for a long push on a button. See 4.2.5 Long Push actions, 
page 33 

Double Push Select action for a double push on a button. See 4.2.6 Double Push 
actions, page 33 

Delayed action Define up to two delayed actions for a Short 
Push. 
If one or two actions will be configured, the 
additional properties for each action will be 
displayed, see 4.2.3 Delayed action 
configuration options. 

No 
1 
2 

1 

2 
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4.2.3 Delayed action configuration options 

Option Explanation Parameters/Examples 

Time Delay Step 1: Delay time until the first delayed 
action starts. 
Step 2: Delay time between the first and the 
second delayed action. 

e.g. 05:00 for 5 hours 

Fade Time Duration in seconds to dim to the new 
brightness level. 

e.g. 1.0 s for one second 

Action Delayed action type: 
- Off (switch off) 
- Go to level (in percent) 

e.g. Go to level 

Level Set the brightness level in percent. e.g. 50 % 

4.2.4 Short Push actions 

The following functionalities are available for Short Push button actions: 

Short Push action Explanation Parameters/Examples 

Disabled   

Off Switch off the light.  

Go to level Light on – dim brightness to parameter 
value. 

Level (0 – 100 %) 

Go to last level Light on – with values from the situation 
before the last light off. 

 

Go to scene /Scene Light on to a configured scene, selected by 
name. 
See 4.3 Add and configure a TW scene, 
page 34. 

Scene name 

Go to next scene Light on to the scene, selected by name. 
If Scene 1 is already running, Scene 2 will 
be recalled by pressing the button – loop 
with each button press.  
See 4.3 Add and configure a TW scene, 
page 34. 

Scenes count (numbers, up to 
five scenes possible), 
Scene names 
 

Toggle (level) Toggle between off and the light value from 
the additional parameter level. 

Level (0 – 100 %) 

Toggle (last level) Toggle between off and the level value from 
the situation of the last light on. 

 

Toggle (scene) Toggle between off and the scene, selected 
by name.  
See 4.3 Add and configure a TW scene, 
page 34. 
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Short Push action Explanation Parameters/Examples 

Go to Color 
Temperature 

Light on a defined color temperature Color temperature in Kelvin 

Go to level and 
color temperature 

Light on a defined color temperature and 
level (in percent) 

Color temperature in Kelvin, 
Level (0 – 100 %) 

4.2.5 Long Push actions 

The following functionalities are available for Long Push button actions: 

Long Push action Explanation 

Disabled  

Dimming Continuous change of the level. With each long push, the dimming 
direction is changed. 

Dimming Up Continuous change to more light (for button with label up). 

Dimming Down Continuous change to less light (for button with label down). 

Change Color Continuous change of color temperature. With each long push, the color 
temperature direction is changed. 

Colder Continuous change to colder color temperature. 

Warmer Continuous change to warmer color temperature. 

4.2.6 Double Push actions 

The following functionalities are available for Double Push button actions: 

Double Push action Explanation Parameters/Examples 

Disabled   

Off Switch off the light.  

Go to level Light on – dim brightness to parameter 
value. 

Level (0 – 100 %) 

Go to scene Light on to scene, selected by name Scene name  

Go to level and color 
temperature 

Light on to selected color and level. Level (0 – 100 %) 
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4.2.7 Configuring a button for multiple TW devices 

If more TW devices should be controlled with one button, you can configure this in Graph panel: 
  

 
 

 Drag a TW device from the device tree to the Graph panel. A new (red) Outputs group is shown. 1.

 Drag the new Outputs group in the Action mapping box. 2.
After this, the new TW device is merged to the existing Outputs group. 

The configured Action mapping is valid for all TW devices in the Outputs group. 

Note: TW Groups and TW DT8 Devices cannot be in the same group. To control TW group and TW 
DT8 with one button, the button has to be connected to both groups by dragging the button into each 
group. 

4.3 Add and configure a TW scene 
Light scenes are intended for the use case that the ECGs in an Outputs group should have different 
color temperatures / levels at the same time. 

It is possible to have one button correspond with up to five scenes (Short Push > Go to next scene). 

4.3.1 Adding a TW scene 

 
 

 Select the required Action mapping box in the Graph Panel, in order to select the outputs that will 1.
be affected by the scene. 

 Click the list (1) and activate the Scene tab (2). 2.

 Click + (3) to add a scene. 3.

 Rename the scene in the window. 4.

1 

2 

3 
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4.3.2 Configuring a TW scene 

In the scene panel, all devices to be affected by this scene are listed. 

Each device in this list can have different brightness and color temperature values, but they also can 
have the same settings. 

  

 

 
 Select the required device (1). 1.

 Select the color temperature (2). 2.

 Select the brightness (3). 3.

 If connected to the controller: Activate Live (4), to visualize the selection.  4.

 Click Go on (5) after final selection to activate the configuration again. 5.

2 2 

3 3 

4 

1 

5 
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 Daylight simulation 5.

5.1 General 
The daylight simulation is using a table of time (including of sunrise or sundown), with defined color 
temperatures and light levels to simulate the daylight in its natural progression through the day. 

 

INFO: This function is only available for the DALI Pro RTC version. 

5.2 Add a daylight simulation sequence 
In the Daylight Simulation window, a sequence of color temperatures can be defined. 

 

 
 

 
 

 Select in the device tree Edit daylight simulation with right mouse click Advanced features > 1.
Effect >Daylight simulation. 

 To add a new sequence, click + in the upper area (1).  2.
A new sequence is added (e.g. Sequenz_2).  
The automatic name of the new sequence can be changed (2). 

 To add a new entry in the sequence, click + in the lower area (3). 3.

1 2 

3 

4 

5 

6 
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 To change the values for time, color temperatue and level, select the entry and insert the values in 4.
the input fields (4). 
A constant light level can be set by activating the Alternative light level at the Start Effect or 
Toggle Effect Short press functionality. 
 
Beside the normal time, relative time to sunrise and sundown times can be used (5).  

 To select your location with corresponding sunrise and sundown settings, click Settings (6).) 5.

5.3 Configure a daylight simulation 
 

 
 

 
 

 

1 

2 

3 

4 
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 Drag the Daylight simulation from the device tree to an Action mapping box in the Graph panel. 1.

 Edit the  Daylight simulation (1) in the Properties window: Set the daylight simulation sequence 2.
(2). For all properties, see the following table. 

 Change the Short Push function to Toggle (Effect)  (4): 3.

 To define a constant light level, activate the Alternative light level property. Define the light level 4.
(in percent). This configuration changes the predefined light levels in the daylight simulation 
sequence.  

 

The following functionalities are available for Daylight simulations: 

Double Push action Explanation Parameters/Examples 

Title Sets the daylight simulation sequence Name of sequence 

Comment Add a comment for further information. e.g. Simulates a summer day 
in auditorium 

Use in zones List zones where the daylight simulation 
is used. 
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 Smartphone Application 6.
This chapter describes how the DALI Smartphone APP can be configured and customized with the 
DALI Professional software. 

  

6.1 General 
INFO: To control a DALI PRO CONT-4 RTC controller with a smartphone, the following additional 

equipment is needed: 
- WiFi router to provide the WiFi 
- RJ45 Cat 5 patch cable between wireless IT-Switch and controllers 

 

INFO: To make the smartphone functionality visible, the smartphone APP feature must be enabled in 
the software (enabled by default). 

6.1.1 Prerequisites 

The following prerequisites must be fullfilled: 

• The DALI controller(s) as well as the Smartphone(s) have access to a common wireless local area 
network (WLAN).  
OSRAM recommends to assign a static IP address for the DALI controller(s). 

• All devices (controllers and smartphones) must be in the same subnet. The DALI PRO CONT-4 
RTC controller is using UDP messages to communicate to smartphone 

• The Laptop/PC with DALI Professional software is connected to the controller via USB. 
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Recommendations for network parameters: 

• OSRAM recommends to assign a static IP address for the DALI controller(s). 

• The subnet must be: 255.255.255.0. 

• The port 23 must not be blocked.  

• UDP Messages must not be blocked. 

 

 
IP Address: 192.168.1.200 

Subnet: 255.255.255.0 
 

IP Address: 192.168.1.xxx 
Subnet: 255.255.255.0 

 

IP Address: 192.168.1.100 
Subnet: 255.255.255.0 

 

 

The DALI PRO Control APP doesn’t work with the cloud. 

 
 
The DALI PRO Control APP doesn’t work with different sub nets. 
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6.1.2 Features 

The APP Configurator of the DALI Professional software supports the following features: 

• Clear and simple structure to configure the APP (tree structure) 

• Multiple elements with adjustable presets configurable 

• Views to group the rooms (visible as pages in the APP) 

• APP configuration analog to standard DALI PRO configuration 

• User control for access restriction 

6.2 Configuring LAN properties 
This section describes the configuration of required WLAN properties for each DALI controller, e.g. the 
device name and IP address. 

When connecting the controller to the LAN, the controller can also be configured via LAN.  
To pretend that everybody in the LAN can configure the controller with the DALI PRO software, the 
access to the controller has to be protected with a password. This password is only needed when 
connecting with the DALI Professional Software via LAN, and can be changed when connecting via 
USB. 

 
 

 Press Set password LAN (1) (Only selectable when connected via USB to the controller) 1.

 Enter a strong password to ensure that the controller cannot be configured via LAN  2.
(NEVER enter your default password!) 

1 
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To configure the LAN properties: 

 
 

 In the device tree, select the controller. 1.

 Click Settings (1) to open the LAN properties window. 2.

 In the LAN properties window, enter a unique device name. 3.

 DHCP is enabled by default. Use this setting and the Wifi Router will provide automatically the IP 4.
address to the controller. (Recommended) 

 If this is not working, use DHCP disabled function (2) and enter a unique IP address.Configure 5.
subnet mask and gateway suitable to your network. 

 Confirm with OK. 6.

  

1 

2 
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6.3  Configuring the APP 
Check prerequisites:  

Check if Smartphone APP feature is enabled in the Project Features list, see 2.1 Enable a feature, 
page 6. 

The APP configurator is located in the device tree in the Advanced features section.  

 

6.3.1 Defining the views 

In the APP, the elements will be grouped in views. Each view defines a page in the APP. 
For eaxmple, the views can represent different rooms: 

 
  



DALI PROFESSIONAL Lighting Control System – Field Commissioning Guide  

v.2.2.x  44/51  

 

6.3.1.1 Adding a view 

 
 

 In device tree, select with right-mouse-click: APP configurator > View > Add view. 1.
A new View_n is created in the tree. 

 In the Properties window, you can rename the view (Title property) e.g. to Office_1. 2.

6.3.1.2 APP elements 

The DALI PRO CONT-4 RTC Controller supports the following APP elements: 

• Button element 
Simple button that can start an action, switch the light; with or without feedback. 
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• Dimmer element 
Button element to switch the light and dimmer element for the dimming level 
 

   
• RGB elements 

Button element to switch the light ,dimmer element for the dimming level and RGB element for the 
color 
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• TW element 
Button element to switch the light and dimmer element for the dimming level and TW element for 
the color temperature 
 

     
 

6.3.2 Adding APP elements to the view 

 To add APP elements to the view: 1.
In device tree, select with right-mouse-click: APP configurator > View > View > Add devices. 
The Add devices window is shown. 
 

 
 Select the number of APP devices in the window and confirm. 2.

The devices will be created in the tree. 

 You can change the Properties of each element, see the following table. 3.

APP element properties: 

Property Explanation 

Title Set the name of the element 

Label Set the label of the element in the APP 

Comment Add a comment for further information 

Zones Show zones where the element is used. 

Visible in Show  the views  where the element is integrated. 

User profile Show the user profiles where the element is enabled. 

Color temperature show numeric value Only for APP TW !     (Yes/No) 
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6.3.3 Configuring the elements 

 
 To assign an APP element to an output device, drag both devices to the Graph panel. 1.

 Connect Inputs and Outputs and configure the properties. 2.
See the example in the upper picture for an Action mapping with APP elements for a TW device. 

 Configure the devices in the Properties window. See 6.3.4. APP element properties, page 48. 3.

 You can rearrange the sort order of the APP elements: 4.
Drag & drop the elements to the position you want or use the functions Up, Down, Delete, Move to 
other view. 
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6.3.4 APP element properties 

The following properties can be set for APP elements: 

Option Explanation Parameters/Examples 

Fade Time 
(only visible for 
button element) 

Duration to dim to the new brightness level. Default (uses fade time stored 
from the ECGs) 
No fade 
0.7 – 90.5 s 

Short Push Select action for a short push on a button. See Short Push actions 
 

Show state Displays the status of the connected output 
(Color or shade of grey to indicate the 
dimming level) 

Yes/No 

Delayed action 
(only visible for 
button element) 

Define up to two delayed actions for a Short 
Push. 
If one or two actions will be configured, the 
additional properties for each action will be 
displayed  
(See the following tables). 

No 
1 
2 

6.3.5 Short Push actions for button and dimmer elements 

The following functionalities are available for Short Push actions for button and dimmer elements. 

Short Push action Explanation Parameters/Examples 

Disabled   

Off Switch off the light.  

Go to level Light on – dim brightness to parameter 
value. 

Level (0 – 100 %) 

Go to last level Light on – with values from the situation 
before the last light off. 

 

Go to Scene Light on to a configured scene, selected by 
name. 
See 4.3 Add and configure a TW scene. 

Scene name (only selectable if 
exist) 

Go to next scene 
(only for button 
element) 

Light on to the scene, selected by name. 
If Scene 1 is already running, Scene 2 will 
be recalled by pressing the button – loop 
with each button press.  
See 4.3 Add and configure a TW scene 

Scenes count (numbers, up to 
five scenes possible), 
Scene names 
 

Toggle (level) Toggle between off and the light value from 
the additional parameter level. 

Level (0 – 100 %) 

Toggle (last level) Toggle between off and the level value from 
the situation of the last light on. 
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Short Push action Explanation Parameters/Examples 

Toggle (scene) Toggle between off and the scene, selected 
by name.  
See 4.3 Add and configure a TW scene. 

 

6.3.6 Short Push actions for TW element 

The following functionalities are available for Short Push actions for Tunable White elements. 

Short Push action Explanation Parameters/Examples 

Disabled   

Off Switch off the light.  

Go to level / 
color temperature 

Light on – dim brightness to parameter 
value. 
change color temperature to parameter 
valve 

Level (0 – 100 %) 
 
Color temperature  
(min. – max.) 

Go to last level / 
color temperature 

Light on – with values from the situation 
before the last light off. 

 

Go to Scene Light on to a configured scene, selected by 
name. 
See 4.3 Add and configure a TW scene. 

Scene name (only selectable if 
exist) 

Toggle (level / color 
temperature) 

Toggle between off and the light value from 
the additional parameter level. 

Level (0 – 100 %) 
Color temperature  
(min. – max.) 

Toggle (last level / 
color temperature) 

Toggle between off and the level value from 
the situation of the last light on. 

Color temperature  
(min. – max.) 

Toggle (scene) Toggle between off and the scene, selected 
by name.  
See 4.3 Add and configure a TW scene. 

 

6.3.7 Short Push actions for RGB element 

The following functionalities are available for Short Push actions for RGB elements. 

Short Push action Explanation Parameters/Examples 

Disabled   

Off Switch off the light.  

Go to level / 
color  

Light on – dim brightness to parameter 
value. 
change color to parameter valve 

Level (0 – 100 %) 
 
Color (RGB values) 

Go to last level / 
color 

Light on – with values from the situation 
before the last light off. 
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Short Push action Explanation Parameters/Examples 

Go to Scene Light on to a configured scene, selected by 
name. 
See 4.3 Add and configure a TW scene. 

Scene name (only selectable if 
exist) 

Toggle (level / 
color) 

Toggle between off and the light value from 
the additional parameter level. 

Level (0 – 100 %) 
Color (RGB values) 

Toggle (last level / 
color) 

Toggle between off and the level value from 
the situation of the last light on. 

Color (RGB values) 

Toggle (scene) Toggle between off and the scene, selected 
by name.  
See 4.3 Add and configure a TW scene. 

 

6.3.8 Delayed action configuration options for button element 

The following functionalities are available for button elements only. 

Option Explanation Parameters/Examples 

Time Delay Step 1: Delay time until the first delayed 
action starts. 
Step 2: Delay time between the first and the 
second delayed action. 

e.g. 05:00 for 5 hours 

Fade Time Duration in seconds to dim to the new 
brightness level. 

e.g. 1.0 s for one second 

Action Delayed action type: 
- Off (switch off) 
- Go to level (in percent) 

e.g. Go to level 

Level Set the brightness level in percent. e.g. 50 % 
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6.4 Define user profiles 
The visibility of the APP elements can be enabled/disabled by user profiles. 
Per default, all configured elements are enabled in the pre-configured user profile User_1. 

This section describes the configuration of additional user profiles (up to maximal 30 profiles). The 
user profiles can be renamed and additional a password can be set. 

 
 

 To add a user profile: 1.
In the device tree, select with right mouse click 
Advanced features >APP configurator >User Profiles > Add user profiles (1) 
A new user profile User_n is created. 

 To rename the user profile and to set a password: 2.
Edit the properties of the created user profile, see following table. 

 To edit the visibility of the APP elements in the user profiles select with right mouse click 3.
Advanced features >APP configurator >User Profiles > Edit user profiles 
The window User profiles in views is shown listing all configured APP elements. 

 In the list, set the X to enable the APP elements (2). 4.

 

Properties of user profiles: 

Property Explanation 

Title Set the name of the user profile 

PassWord Enter a password  for the user profile 

Comment Add a comment for further information 

 

1 
2 
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